Incident affecting Startpage.com in Europe
Incident Report for Startpage
Resolved
This incident has been resolved.
Posted Dec 10, 2024 - 15:57 UTC
Investigating
We are addressing an incident that began on Friday in our European data center. While the issue is largely resolved, some users may still face difficulties connecting to Startpage. If you're encountering any problems, we encourage you to reach out to us at support@startpage.com. Thank you for your patience as we continue to look into this issue.
Posted Dec 09, 2024 - 18:28 UTC